Page 1 of 1

Engine "Barry Mounts"

PostPosted: Wed Jul 27, 2016 8:44 am
by alan
Greetings.

After 8 or 9 years with no problems, my engine mounts have started to deteriate. This seems like a reasonable lifespan. I remember when I replaced the last set that someone on this site recommended a certain kind of lubricant during installation.

Would someone please remind me?

Thanks,

Alan

Re: Engine "Barry Mounts"

PostPosted: Wed Jul 27, 2016 10:27 am
by FlyerChief
Hi Alan,
Check out this thread from 2008... http://www.wingsforum.com/viewtopic.php?f=218&t=12772&p=14809&hilit=lord+mounts#p14809

In one of your posts, you mention "Silicone Grease".
Dan

Re: Engine "Barry Mounts"

PostPosted: Wed Jul 27, 2016 11:28 am
by alan
Thanks for that link Dan. That was exactly what I was looking for. :D

Now just have to find some silicone grease. Probably in the Just Aircraft section at Home Depot. :lol:

Alan

Re: Engine "Barry Mounts"

PostPosted: Wed Jul 27, 2016 11:41 am
by Tralika
I just bought some at Napa, couldn't find it at Home Depot.

Re: Engine "Barry Mounts"

PostPosted: Thu Jul 28, 2016 8:26 am
by alan
Actually got it at Auto Zone along with some K&N filter oil.

Could only get to the front 4 mounts because of coolant hoses. The only mount that looked bad was the front port side. Since the rest look brand new after so long I don't feel bad at all about leaving the back two alone. Detaching those two coolant hoses would be asking for trouble. When the rubber starts to harden I'll replace all the hoses.

Also, the multi-purpose grease I used on the last Barry mount replacement didn't hurt them at all, so now I just have to hope the silicone grease will be ok. :D

Alan