Engine "Barry Mounts"

For general discussion of the Just Aircraft family of aircraft.
Includes: Highlander, Escapade, Summit and SuperSTOL.

Moderator: scubarider2

Engine "Barry Mounts"

Postby alan » Wed Jul 27, 2016 8:44 am

Greetings.

After 8 or 9 years with no problems, my engine mounts have started to deteriate. This seems like a reasonable lifespan. I remember when I replaced the last set that someone on this site recommended a certain kind of lubricant during installation.

Would someone please remind me?

Thanks,

Alan
If I had known I would live this long I would have taken better care of myself.
User avatar
alan
Veteran Member
 
Posts: 342
Joined: Fri Feb 04, 2005 1:39 am
Location: Baytown, TX

Re: Engine "Barry Mounts"

Postby FlyerChief » Wed Jul 27, 2016 10:27 am

Hi Alan,
Check out this thread from 2008... http://www.wingsforum.com/viewtopic.php?f=218&t=12772&p=14809&hilit=lord+mounts#p14809

In one of your posts, you mention "Silicone Grease".
Dan
When everything seems to be going against you, remember that the airplane takes off against the wind, not with it. ~Henry Ford
User avatar
FlyerChief
Veteran Member
 
Posts: 261
Joined: Tue Nov 03, 2009 9:53 pm
Location: Ontario, Canada

Re: Engine "Barry Mounts"

Postby alan » Wed Jul 27, 2016 11:28 am

Thanks for that link Dan. That was exactly what I was looking for. :D

Now just have to find some silicone grease. Probably in the Just Aircraft section at Home Depot. :lol:

Alan
If I had known I would live this long I would have taken better care of myself.
User avatar
alan
Veteran Member
 
Posts: 342
Joined: Fri Feb 04, 2005 1:39 am
Location: Baytown, TX

Re: Engine "Barry Mounts"

Postby Tralika » Wed Jul 27, 2016 11:41 am

I just bought some at Napa, couldn't find it at Home Depot.
John Nealon
Wasilla, Alaska
Highlander Extreme #191
mykitlog.com/jnealon
Tralika
Veteran Member
 
Posts: 210
Joined: Thu Oct 08, 2009 12:49 pm
Location: Wasilla Alaska

Re: Engine "Barry Mounts"

Postby alan » Thu Jul 28, 2016 8:26 am

Actually got it at Auto Zone along with some K&N filter oil.

Could only get to the front 4 mounts because of coolant hoses. The only mount that looked bad was the front port side. Since the rest look brand new after so long I don't feel bad at all about leaving the back two alone. Detaching those two coolant hoses would be asking for trouble. When the rubber starts to harden I'll replace all the hoses.

Also, the multi-purpose grease I used on the last Barry mount replacement didn't hurt them at all, so now I just have to hope the silicone grease will be ok. :D

Alan
If I had known I would live this long I would have taken better care of myself.
User avatar
alan
Veteran Member
 
Posts: 342
Joined: Fri Feb 04, 2005 1:39 am
Location: Baytown, TX


Return to Just Aircraft